Shopware - Shopware PaaS Native - Degraded background task processing – Incident details

Application Services under maintenance

Shopware PaaS Native - Degraded background task processing

Resolved
Degraded performance
Started about 15 hours agoLasted 33 minutes

Affected

Shopware PaaS Native

Degraded performance from 1:32 PM to 2:05 PM

Infrastructure Services

Degraded performance from 1:32 PM to 2:05 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Identified
    UTC
    Identified

    We are currently addressing an issue affecting background task processing for some PaaS Native shops.

    The issue was introduced by a recent change to worker auto-scaling, which can cause scheduled tasks to remain locked for several minutes and delay their processing.

    We have identified the cause and are rolling out a fix. The update has been successfully tested, and we expect it to be fully deployed within approximately 30 minutes.

    We will provide another update once the fix has been rolled out.

    Impact: Some PaaS Native shops may experience delays in scheduled and background task processing.